Author Topic: Links not being posted completely  (Read 9367 times)

Offline allyours

  • Jr. Member
  • **
  • Posts: 94
    • All Yours Chat
Links not being posted completely
« on: August 15, 2006, 07:51:30 AM »
Account Name: allyourschat

When I post the links on our box
Code: [Select]
http://allyourschat.com/beta/it appears as -link- at.com/beta/
When I post the link
Code: [Select]
http://allyourschat.com/beta/faq.htmlit appears as -link- at.com/beta/faq.h tml
So what's up?


Where friends make new friends

Offline FiXato

  • Co-Net-Administrator of Chat4All IRC Network
  • Administrator
  • Hero Member
  • *****
  • Posts: 1403
  • Dutch Developer in between countries and jobs
    • FiXato.co.uk
Re: Links not being posted completely
« Reply #1 on: August 15, 2006, 10:48:21 AM »
I believe this has to do with the word-wrap function that prevents the shoutbox to be stretched horizontally if some text is too long.
Using the [link] bbcode instead, should prevent it from happening with links :)

Adonis can probably explain it a bit better though ;p

Offline allyours

  • Jr. Member
  • **
  • Posts: 94
    • All Yours Chat
Re: Links not being posted completely
« Reply #2 on: August 15, 2006, 03:10:24 PM »
Thanks FiXato
Well past experience has certainly given me an appreciation for the word wrap. :)
But I had already tried the UBBC [link] function same thing. So coders, please take a look and see if there is something to do to workaround this problem. Posting links is an important feature we need.


Where friends make new friends

Offline allyours

  • Jr. Member
  • **
  • Posts: 94
    • All Yours Chat
Re: Links not being posted completely
« Reply #3 on: August 15, 2006, 03:44:53 PM »
Well allow me to apologize about what I said in using the UBBC [link] and the link not working properly. Seems that trying to use it in the CP when Editing the shout will not allow the post to be corrected and display the link properly. I just did a test shout directly into the shoutbox with the UBBC and it worked fine.

Still, it seems like a bug if we can't edit a shout to display the link correctly by using UBBC from the CP. Also, it still would be nice that since links are displayed -link- that URL's are an exception from the wrap feature.


Where friends make new friends

Offline Adonix

  • Administrator
  • Hero Member
  • *****
  • Posts: 879
    • Chat4all
Re: Links not being posted completely
« Reply #4 on: August 15, 2006, 06:23:54 PM »
The UBBC [link] feature was a "quick fix" after implementing the wordwrapper. The normal conversion to links outside the UBBC should not work at all, but that requires some more coding... more than just a quick fix. A heritage from the previous owner.

The whole USBC coding has been completely rewritten (much better), but can't be implemented yet because of its dependencies in other files.

The shoutbox service will be getting an overhaul the coming months, as more code will be changed and more functions will be better. This has been going on since we acquired it. Many things have changed and many things will be changing in the near future :)

I'll look at the CP to see what i can change there.  :bling:
Tempus fugit et nos fugimus in illus
- Ovid Fasti


Offline allyours

  • Jr. Member
  • **
  • Posts: 94
    • All Yours Chat
Re: Links not being posted completely
« Reply #5 on: August 15, 2006, 06:59:33 PM »

I'll look at the CP to see what i can change there.  :bling:

Thanks, that would be SUPER! :D


Where friends make new friends

Offline Adonix

  • Administrator
  • Hero Member
  • *****
  • Posts: 879
    • Chat4all
Re: Links not being posted completely
« Reply #6 on: August 15, 2006, 11:19:52 PM »
Quote
Still, it seems like a bug if we can't edit a shout to display the link correctly by using UBBC from the CP. Also, it still would be nice that since links are displayed -link- that URL's are an exception from the wrap feature.

I just checked from the CP, and i can change wordwrapped urls there perfectly fine. Just remove the spaces in the url and it will display it correctly, even without the UBBC [link]. This is because the wordwrap (currently, migt be changed)) only takes effect when writing the shout to the database.

The wordwrap feature does make an exception for URL's. When the script sees [link] url [/link] it will excempt anything between those tags from being wordwrapped.

Having said that.. the admin CP will still need changes. For example, making it easier to delete shouts. Currently, if you have 5000 shouts, it will list them all without pagination. Which is not good. Pagination is the first thing on my list that needs to be changed.

Also deleting the whole "bad word" thing from the script. The script currently force changes certain bad words to *removed* , but i'd like to leave the bad word identification to the webmasters themselves through the admin cp.
Tempus fugit et nos fugimus in illus
- Ovid Fasti


Offline allyours

  • Jr. Member
  • **
  • Posts: 94
    • All Yours Chat
Re: Links not being posted completely
« Reply #7 on: August 16, 2006, 06:27:25 PM »
I was able to edit one URL and it made the correction from the CP. For some reason, that was the only post that would accept the edit by removing the spaces. Tried it on other posts but it kept returning to spaces thus not allowing the -link- to properly display.

While we're on some of the features about the CP, I noticed there is no "good" way to ban. As I see it now we need to 'copy' the IP and place it in the IP bans.

I'm going to PM you the URL of a mock-up of our home page with the chat4all shoutbox.


Where friends make new friends

Offline Eve420

  • Newbie
  • *
  • Posts: 5
Re: Links not being posted completely
« Reply #8 on: October 23, 2006, 09:59:09 AM »
Quote
When I post the links on our box

Code:
http://allyourschat.com/beta/it appears as -link- at.com/beta/
When I post the link

Code:
http://allyourschat.com/beta/faq.htmlit appears as -link- at.com/beta/faq.h tml

Are there any updates on this topic.... the mentioned quote above is the problem I am having.

Thanx, Eve

Offline Adonix

  • Administrator
  • Hero Member
  • *****
  • Posts: 879
    • Chat4all
Re: Links not being posted completely
« Reply #9 on: October 23, 2006, 08:34:36 PM »
Hi Eva,

Links inside shoutboxes should be encapsulated between [link] [/link] . Like [link]www.chat4all.org[/link]. That way it bypasses the feature we added a while ago which cuts very long words.

The original shoutbox feature was such that links were created automatically, but that didnt work well anymore after the wordwrap feature was added. That's why we came up with the [link] [/link] idea to get past this problem.
Tempus fugit et nos fugimus in illus
- Ovid Fasti


Offline Eve420

  • Newbie
  • *
  • Posts: 5
Re: Links not being posted completely
« Reply #10 on: October 24, 2006, 02:46:16 PM »
ok thanks